admin 发布的文章

升级node到最新的文档版本后,发现出了不少问题,error @achrinza/node-ipc@9.2.2: The engine "node" is incompatible with this module. Expected version "8 || 10 || 12 || 14 || 16 || 17". Got "18.16.0"这是因为脚手架中的node-ipc 版本兼容问题导致的首先使用命令可以尝试更新@achrinza/node-ipcnpm update @achrinza/node-ipc 如果不好使可以更新下脚手架npm -i g @vue/cl- 阅读剩余部分 -

OpenAI 是什么来自 WikiOpenAI 是一家美国人工智能(AI)研究实验室,由非营利性 OpenAI Incorporated(OpenAI Inc.)及其营利性子公司 OpenAI Limited Partnership(OpenAI LP)组成。OpenAI 进行 AI 研究的目的是促进和开发友好的 AI。OpenAI 系统运行在世界上第五强大的超级计算机上。该组织于 2015 年由 Sam Altman、Reid Hoffman 在旧金山成立,杰西卡·利文斯顿(Jessica Livingston)、埃隆·马斯克(Elon Musk)、伊利亚·萨茨克维尔(I- 阅读剩余部分 -

uniapp 原生自带,偷懒搬个demo 传送门<template> <view class="page-body"> <page-head title="movable-view,可拖动视图"></page-head> <view class="uni-padding-wrap uni-common-mt"> <view class="uni-title uni-commo- 阅读剩余部分 -

实现原理是基于uniapp的uni.$on、uni.$emit uni.$off监听实现的。首先在当前页面增加onUnload生命周期函数 onUnload() { uni.$emit('refresh'); }, 然后在上一级组件里面增加onLoad(opts){ console.log('opts',opts) uni.$on('refresh',() => { this.getWorkOrderUnShelveMaterialList() }) }, onUnload(){ console.log('onUnload') - 阅读剩余部分 -

node升级18之后老项目运行吧报错备注:node版本高于16就会报错解决方案1.最直接的办法:将 node.js 版本降到 v16+2.在项目package.json的在对应运行指令增加命令windows 在终端处输入$env:NODE_OPTIONS="--openssl-legacy-provider" 或 set NODE_OPTIONS=--openssl-legacy-provider 补充:在终端输入一次只能本次生效,如果想永久生效可以在 package.json 文件中修改对应的 scripts 节点的内容如下:"serve- 阅读剩余部分 -