npm run dev 错误提示:

{ parser: "babylon" } is deprecated; we now treat it as { parser: "babel" }.

解决方法:

找到你的工程文件夹里的 YourProName\node_modules\vue-loader\lib\template-compiler\index.js

//将以下代码
if (!isProduction) {
  code = prettier.format(code, { semi: false, parser: 'babylon' })
}
 
//修改为:
 
if (!isProduction) {
  code = prettier.format(code, { semi: false, parser: 'babel' })
}

标签: vue, vue-cli报错

添加新评论